Installing JS/UML

Eclipse Prerequisites

Model Tree

  • JS/UML 0.9.3 is known to work with Eclipse Mars.2 (4.5.2)

  • For best results use the version "IDE for Java EE Developers"

  • You must install the "Papyrus UML" feature (Help -> Install New Software...)


  • Download the distribution named "jsuml-eclipse" from the download page

Install in Eclipse

  • Do not unzip!

  • In Eclipse go to Help menu -> Install New Software...

  • Click the "Add..." button, then the "Archive..." button and choose the downloaded jsuml-eclipse file

  • When the selection dialog appears, select the "JS/UML" feature

  • Follow the wizard to install JS/UML and its dependencies

Verify Install

  • After installing JS/UML restart Eclipse

  • If the plugin is installed correctly it will appear in the list available from the Help menu -> About Eclipse -> Installation Details -> Plug-ins tab

  • When everything is verified to be working, see the Quick Start guide